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1. Before You Begin

1.1
You will see helpful icons used in this guide to draw attention to a subject, action or information.

E’ 2 The light bulb icon indicates information that is likely to make your job easier.

]3 The exclamation icon highlights a warning or an action you need to take. When you see this
icon, pay attention and proceed with caution.

@ The ‘i’ for information icon indicates an area that assists in a decision.
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2. Setting up HealthLink with Medical Director

The Scheduled Document Import (SDI) utility facilities Medical Director with the ability of automatically
import messages. The user can configure SDI to run at a regular interval.

2.1

When HealthLink Messaging Client is installed, it creates an interface file called hms_config.xml
located in the C:\HLINK directory. The interface file contains the file path details for all the incoming and
outgoing directories for the different message types. MD3.10 or later looks for this file on the local
Computer and uses the file to find the appropriate paths for its messages.

2.2
1. Click Tools > Manage Communications > General.

{‘ Manage Communications X

General Setup Data Transfer Advanced Pathology Message Tracking
Import Configuration Recognised File Extensions

Import Database |m Live Data v | ACK

Automatic Import Interval | 2minutes v cQp

2. Select MD Live Data for the Import Database drop down box under General tab.

3. Select the desired automatic import frequency from Automatic Import Interval drop down
box.

4. Click Close to the bottom left of the screen to save the changes.

5. A pop-up screen will confirm if you would like to save the changes, click Yes to confirm
changes.

6. A screen will pop up advising that the SDI will be tested click on OK for SDI to start trial
import.

7. When the test is successful click OK.
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3.

Setting up HealthLink Imports and Smart Forms
within Medical Director

6.

7.

8.

Go to Start > All Programs > HealthLink Advance Options.

Click on Configuration > User Settings.

Click on Message Types Tab.

Select the LAB2 message type and click on the Messages Stores tab on the lower half of

the screen.

Click on the Edit/ More button and change the incoming and outgoing file paths. Click on the

Close button to close the screen.

HL Message Directories

Use local UNC path for highlighted segments

Outgoing Messages
Outgoing Message Directory
\\DESKTOP-ITKF20THLINK\HL7_out\AB2 | | o |
Outgoing Message Error Directory

C\HLINKHL7_out) AB2Vejected [ =]

Incoming Messages
Incoming Message Directory
\\DESKTOP-ITKF20THLINK\HL7_in\LAB2 | | = |
Incoming Message Error Directory
C:HLINKVHL7_in\_AB2yejected [ ]

=

C:HLINK\HL7_in\LAB2yejected

Acknowledgement Messages Archived Messages

Acknowledgement Message Directory Qutgoing Message Archive Directory
\\DESKTOP-ITKF20TWHLINKIHL7_in\LAB2 || . | |C:VHLINKIHL7_out\AB2\archive =]
Acknowledgement Message Error Directory Incoming Message Archive Directory

|C:V-LMV-I.?_h\LABZ\ardive

[ Gooe || Concd |

Make the same changes to RSDAU, PIT, and BROADCST.

Click on File > Save All to save the changes made.

Click on File > Exit to exit out of HealthLink Advance Options.
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1. From the Medical Director’'s main tool bar choose Tools > Manage Communication.

0 MedicalDirector Clinical 4.3
Open File Patient User | Tools | Clinical Correspondence Search Resources Sidebar Messenger Help

Letter Writer... F8
Labels...

X-ray View Screen Ctrl+Shift+X
Calculators >

Medicare Australia PK| Certificate Manager
Options...
Print Options...

Manage Communications...

MDExchange >
Patient Photo Options

HealthLink >

2. In General Tab, look up Recognised File extensions list for REF.

3. If REF extension is not in the list, add .REF extension to the list.

4. Click on Setup Data Transfer tab.

5. Medical Director will automatically look at the HealthLink Interface file in C:\HLINK.

6. If HealthLink is not installed on the C:\ drive, then browse to the HLINK folder and select the
HealthLink Interface File Path hms_config.xml.

7. Click on the Refresh HealthLink Import Path(s) button to load the HealthLink settings. This
will populate the Manage Communications settings with the HealthLink file paths.

8. Tick on the Global check boxes for LAB2, RSDAU, PIT and BROADCST (if in Southern
Australia).

9. Untick the ACK boxes for PIT and BROADCST (if in Southern Australia).
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10. The completed Setup Data Transfer configurations will look like the screenshot below.

4% Manage Communications

General Setup Data Transfer Advanced Pathology ~Message Tracking

Filter by Category ‘ All

~ ‘

Description Category ¢ | Import Folder Export Folder SDI | Manual | ACK | Global | »
BROADCST HealthLink \\Desktop-itkf2otthi... |\\Desktop-itkf2otihii... | W 72 O v
HDOCS HealthLink C:\HLINKWML _inthe... |C:\HLINKWML outth... | W v v r
HIRAD HealthLink C:\HLINK\HL7_in\HL... |C:\HLINK\HL7 out\H... | W v v r
HLK_HELP HealthLink C:\HLINK\pther_in'H... |C:\HLINK\other_out\... | W v v r
HLKFAX HealthLink C:\HLINK\other_in\fax\ | C:\HLINK\other_out\... | W v v -
LAB HealthLink C:\HLINK\FF_in\LAB\  |C:\HLINK\FF_out\LAB\ | ™ v v -
MDMO 1AU HealthLink \\Desktop-itkf2otihli... |\\Desktop-tkf2otihli.. | W 2 I’2 ~
MEDDOCS HealthLink C:\HLINK\FF_in\MED... |C:\HLINK\FF_out\ME... | ™ v v -
NSWEHR HealthLink CHHLINKWHL7_in\NS.... |C:\HLINK\HL7 out... | W v v r
PIT HealthLink \\Desktop-itkf2otihli... |\\Desktop-tkf2ot\hli... | M 2 O v
RSDAU HealthLink \\Desktop-itkf2otihli... |\\Desktop-itkf2ot\hli... | W 72 I v
MD Directory Standard C:\Program Files (x8... | C:\Program Files (x8... | W v r v

| .| | Refresh Healthlink Import Path(s)

HealthLink Interface File Path |C:HMms_cmﬁg.mi

add || Edt || Deete |

11. C

lick on the close button to save any changes.

T If any changes are made to HMS Advanced Options, refresh HealthLink import

5]

paths(s) from setup data transfer tab for Medical Director to pick up the settings.
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HealthLink smart forms settings should be automatically configured by Medical Director. However, if
this has not been configured use the steps below to update the HealthLink forms settings.

1. From Medical Director’'s main tool bar choose Tools > HealthLink > Setup.

2. Inthe HealthLink Setup screen setup section click on [.] from the HealthLink Interface File
Path to load hms_config.xml file.

HealthLink Setup X
~ Setup
HealthLink Interface File Path | Desktop-tkf 20t \hlink\hms _corfig x | EI
EDI Account HealthLink EDI | Passwerd [~ |
Forms Director Url [hitp://DESKTOP-ITKF20T-5088 |
Last Modified 22/12/2023 08:17.23.00 | Viewlogs | Refresh HealthLink
I Web Service

NOTE: Changes can only be made via the MD server computer ~ Service is running and connected to a database

HostName  [DESKTOP-TKF20T | Database Server | DESKTOP-TKF20T\HCNSQLO7 |

Pt T Osateetine [ |

Web Service URL |Htp://DESKTOF-IT1ﬂ:Z)T:908WMmFomSm |

| Restat HCN Service Manager | View Web Service logs | Refresh | Save |

3. Click on Refresh HealthLink for Medical Director to automatically populate all the required
boxes.

4. Check and confirm that the Medical Director Service is running in the Web Service section of
the setup screen as circled in screenshot below.

HealthLink Setup X
[ Setup
HealihLink Interface File Path  |}\\Desktop-tkf2ot\hlink\hms_config xml | ]
EDI Account | HealthLink EDI | Password -]
Forms Director Url |ttp://DESKTOP-TKF20T:5088 |
Last Modified 22/12/2023 08:17:23.00 | Viewlogs | Refresh Healthlink |
[ Web Service

NOTE: Changes can only be made via the MD server computer ( Service is running and connected to a database

Host Name |DESKTOPTKF20T Database Server | DESKTOP-TKF20 T\HCNSQLO7

Fort No. Tex Database Name [HCN |

\web Service URL |http://DESKTOP- TKF20T:9080/AduroFormSession |
| Restart HCN Service Manager | View Web Service Logs | Refresh  Save

5. If the Medical Director Service is not running, refer to the appendix section of this document
to start the Medical Director Service.
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4. Setting up the RSDAU, CDA Messaging

Incoming RSD and Correspondence storage (Referrals, Specialist letters, Discharge Summaries) can
be filed in Documents or Letters tab within patients’ notes.

To set this up:

1. From the main tool bar, choose Tools > Options and select the RSD tab.
Options X
General Prescribing Progress notes  Practice Lists Investigations
Dug/Patient Suppott ~~ Devices  PKI Recal
y The Referal, Status and Discharge Summary system allows you to receive
electronic status and discharge summaries.

Status and Discharge Summary Reports Storage

You can specify where you would like status and discharge summaries
stored.

(O File reports in the Letters tab of the Clinical Window
(® File reports in the Documents tab of the Clinical Window

Comespondence Storage

You can specify where you would like comespondence such as letters and
summaries stored.

(®) File comespondence in the Letters tab of the Clinical Window
O File comespondence in the Documents tab of the Clinical Window

CDA messages are always filed to the Letters tab.

[M Auto-capitalise names Save |‘ Cancel 1

2. Select the File reports in the Documents tab of the Clinical Window option.

3. Click on Save to save the change.
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5. Testing Your Configuration

1. Open the HealthLink Advanced Options.

2. From the menu click Utilities > Test Message Generator. The Test Message Generator
window will open.

3. The sending and receiving EDI account will automatically fill with the practice EDI.

4. To generate a LAB2 message click on LAB2 from Message Types available to you and then
click on the Generate Test Message button.

1. To generate a RSDAU message click on RSDAU from Message Types available to you and
then click on the Generate Test Message button.

2. Click on File and Exit to close the HealthLink Advanced Options.

1. From the systems tray right click the HealthLink IEI Icon.

2. Left click on Run Now to make the manual connection.

Stop Healthlink Messaging Service

View HealthLink Event Log

View HealthLink Error Log
Run Nowd
H H “ ” & H H . . . . .
3. A spinning “H icon indicates the HealthLink client has started its connection.

4. Once the “H” stops spinning, the HealthLink connection has been completed and the
test messages are downloaded into their respective folders for Medical Director to
import.
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6. Checking Messages in Medical Director

1. To check message that have been imported into Medical Director, press the F5 key or
alternatively, from the Medical Director menu, click Investigations > Check Holding File
(the message import is done automatically if the SDI functionality is on).
B Itis advisable not to use F4 key from the keyboard to manual import, since SDI
. functionality can be scheduled to desired interval to import the diagnostic reports,
referrals and discharge summaries automatically.
2. Select the name of the Doctor for which you want to view the investigation results and click
the OK button.
Check Holding File
Select Recipient(s)
All Recipients
Dorevitch
Dr A Practitioner
3.

A list of the current messages will be displayed with message preview. To get to a full
preview double click on the message you want a full preview of.

) MedicalDirector Clinical 4.3 - [Holding File]
B File Edit Patient Action Window Help

Preview - Full ~ | Hide Preview | ClearFilters | Move Location | Document Details | Scan ~ | Import ~ | Print ~ Prntlist ~ | Delete Refresh = Send Via MDX l
10f 1 Records e
Date Collected| 7| | Patient [7) Subject [7)|4#(7) Recipient/Doctor (7] Sender/Provider [ 7]| N'7] C[7] Type [7]| Description [7)| Date Requeste 7|
< 3>,
2| Name: MOUSE. MICKEY Middie A | Subject RSD - Discharge Referal |
Address: 1 TESTING STREET
WOONONA. 2517 Lab. Reference:
D.0B-30/01/1981 Sex at Bith: M
Ne Requesied: Complete: Fral
IHI No: Performed: 12/07/2024
Lab. Reference: N
Date Requesied: 12/07/2024 + | Sender/Provider:
Zoom Page Width ~ | Open Extenally = View PDF | View RTF Page: 10f 2
Pages =
313 Burwood Rd HAWTHORN 3122
ol Ph: 9818 5488
Dr Demo Doctor
Qualifications
0000000Y
v
- v

Previous = Next | Reassign Patient | Assign Recipient = Action | No Action = Discuss | Return Urgently =~ Add Recall = Edit Patient = Open Patient = View Signature | Audit History | Close

# New look inbox in MD 3.18a onwards provides the user with a lot of new options
2 such as Assigning Reports, Deleting one or more messages etc from the preview

screen. The message preview can be changed using the Preview button on the top left
hand conner.
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7. Appendix

If Medical Director’'s HCN Service Manager is not started, use the steps below to start the HCN Service
Manager.

1. Click on Start > Run. In the Run window type “services.msc” and click on the OK button.

2. From the Windows services screen look for HCN Service Manager and double, left click to
open HCN Service Manager Properties window as shown below.

3. Select “Automatic” from the Startup type.

4. Click “Start” from the Service status and then click on the OK button.

HCN Service Manager Properties (Local Computer) X

General LogOn Recovery Dependencies
Service name:  HCNServiceManager
Display name: HCN Service Manager

Description: Host service for multiple serviett plug-ins. I this
' service is stopped then all plug-ins are also stopped.

Path to executable:
“C:\Program Files (x86)\Health Communication Network\HCN Service Manz

Statuptype: | Automatic v

Service status:  Running

Start Stop Pause Resume

‘You can specify the start parameters that apply when you start the service
from here.

Start parameters:

1. Open the test patient Mickey Mouse.

2. From patient screen click on the HealthLink Tap i Heatnlrk

3. Once in the HealthLink Tab, click on the [Enewfom | button to load HealthLink smart forms
homepage.

HL HealthLink

Contact Us
connecting with care

Make a referral | Update referrals |

Specialists, Allied Health Providers and GPs

‘ BR| specialists & Referrals Refer to Private Specilist

General Services

Medical Director 4.3 26/07/24 Integration Guide 14
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If the practice has moved to another EMR system from Medical Director, the practice needs to make
user HCN Service Manager is disabled.

Click Tools > Manage Communications and select (disabled) from the Import database drop down
box.

If the practice has started using a new Clinical Software System, it is possible that HCN Service
Manager may still be running hence pulling the messages out of the default Healthlink messaging
folders.

To stop any messages been pulled by the HCN Service Manager the HCN Service Manager needs to
be disabled.

This service starts automatically and to stop this service you will need to change the startup type to
“disabled” in the Windows Services screen.

1. Click on Start > Run. In the Run window type “services.msc” and click on the OK button.

2. From the service screen look for HCN Service Manager and double, left click to open HCN
Service Manager Properties window as shown below.

HCN Service Manager Properties (Local Computer) X
General |ogOn Recovery Dependencies

Service name:  HCNServiceManager
Display name:  HCN Service Manager

Description: Host service for multiple serviett plug-ins. If this
) #aviceissioppedmmﬂpbghsa'edsostopped,

Path to executable:
"C:\Program Files {x86)\Health Communication Network\HCN Service Manz

Statuptype: | Disabled v

Service status:  Running

Start | Stop | Pause Resume

You can specify the start parameters that apply when you start the service
from here.

Start parameters

[ ok ]| canced || Ay |

a. Select “Disabled” from the Startup type.
b. Click “Stop” from the Service status and then click on the OK button.
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8. Medical Director Support Contact Details

Phone: 1300 300 161

Web: https://www.medicaldirector.com/contact
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New Zealand
Phone toll free: 0800 288 887
8.00am — 5.00 pm Monday-Friday

Australia

Phone toll free: 1800 125 036
7.00am — 7.00 pm Monday-Friday
(AEST)

Email
helpdesk@HealthLink.net

If there is a communication problem.

Make it our problem.

www.HealthLink.net



